DeutschEnglish

Submenu

 - - - By CrazyStat - - -

20. September 2017

How to find out the real name belonging to an email address for 1 cent through paypal

Filed under: Security,Uncategorized — Christopher Kramer @ 18:36

Paypal allows you to transfer money to your friends and family. To do so, you just need the email or phone number of the recipient. I just did this and noticed something interesting: I just gave the email address of the recipient, but in the list of transactions, paypal shows the full real name of my friend as recipient, and also sent me a mail that contains the full name. This means, you can easily find out the real name assigned to some mail address that is used as a paypal account by just sending a cent to the address. Of course the recipient will notice it, but probably will not complain.

This is especially interesting as paypal itself says in the footer of every email that scam mails will usually not include your real name. But scammers could first send you a cent to find out your real name and then greet you with your real name in the scam mail.

It seems to be a good idea to use an email address for paypal that you use nowhere else. This way, it is not possible to find out your real name through your normal mail address. Additionally, this has the advantage that you can ignore any phishing mail that you receive in the name of paypal, but through your normal mail address and not your paypal mail address.

Recommendation

Try my Open Source PHP visitor analytics script CrazyStat.

22. April 2015

HTML5: why is my comment a ‘bogus comment’!?

Filed under: Uncategorized — Tags: , , , , — Christopher Kramer @ 12:52

I checked the validity of an HTML5 document (using the HTML Validator extension for Firefox, which I highly recommend) and found an error about a “bogus comment”. The comment looked normal:

<!–– some comment ––>

Then I read the HTML5 specification and found out that the bogus comment state instead of the “normal” comment state is entered if after “<!”, the parser cannot find two dashes. I remembered that I had copied the comment from the web and not typed it myself, so I deleted the –– and typed them manually. Looking closely, you can see the difference:

<!–– some comment ––>
<!-- some comment -->

After that, the bogus comment error was gone.

So the reason was that the – signs were not “normal”, but some other characters for longer dashes that look similar. So whenever you see a “bogus comment”, try to type the comment tags yourself…

Hope this helps somebody.

19. March 2015

Owncloud: Share-Button for calendar is missing

Filed under: Uncategorized — Tags: , , — Christopher Kramer @ 16:04

Searching the share-Button for the calendar in your owncloud webinterface?

I was searching it and finally found out that adblock was removing it! “Fanboy’s Social Blocking List” includes a rule “###.icon-share”, which also removes Ownclouds-Share button.

So best, just disable Adblock for your owncloud server.

7. November 2014

Amazon Instant Video and Error 1002

Filed under: Uncategorized,Windows — Tags: , , , , , — Christopher Kramer @ 20:40

Recently, when trying to watch a video in Amazon Instant Video, I only got Error 1002. I tried Firefox, Chrome, Opera and Internet Explorer and none of them worked. I reinstalled Silverlight and this also did not help.

Then finally I found the reason: Amazon still seems to use SSL 3 for Instant Video streams! Because Google recently reported security problems with SSL 3.0 (known as the POODLE security vulnerability), I disabled SSL 3.0 in all browsers including Internet Explorer. No matter what browser you use, Silverlight will use Internet Explorer’s settings and will not use SSL 3.0 any more. Re-enabling SSL 3.0 again in the Internet Explorer settings fixed the problem with Amazon Instant Video. As I am not really using Internet Explorer anyway, I don’t care much about this, but Amazon should really work on this to make Instant Video available without the need to enable SSL 3.0.

Happy streaming!

10. April 2014

Inkscape: Change Arrowhead color

Filed under: Linux,Uncategorized,Windows — Tags: , , , , , — Christopher Kramer @ 18:55

In Inkscape, a great open source vector graphics program, when you change the stroke color of a path, the arrow heads still remain black. But there is a way to change their color, although quite unintuitive.

This is how it looks like:

Inkscape: arrows with same arrowhead color as the path

Inkscape: arrows can have the same arrowhead color as the path

And this is how its done:

  1. Mark the Path you want to change the color of the arrowhead
  2. “Extensions”
  3. “Modify Path”
  4. “Color Markers to Match Stroke”

That’s it!

inkscape_arrows_color

Update: Inkscape 0.91

In Inkscape 0.91, this problem is “fixed”: The arrowhead automatically gets the Stroke-color assigned and the extension mentioned above is gone. But:

Sometimes when I change the stroke color, the arrowhead does not get updated. In this case, you can adjust the arrowhead color like this:

Select the arrow, double click the color next to “Stroke:” on the lower left of the screen, it opens the window to adjust the stroke color and without doing anything in this window, it magically adjusts the color of the arrowhead.

1. April 2014

Outlook 2010: Nachrichtenkopfzeilen (Header) anzeigen

Filed under: Uncategorized — Tags: , , — Christopher Kramer @ 18:15

So kann man sich in Outlook 2010 die Header anzeigen:

  • Nachricht öffnen (doppelt anklicken).
  • Bei “Kategorien” auf den kleinen Pfeil unten rechts klicken
    outlook_header
  • Unter “Internetkopfzeilen” finden sich die Header:
    outlook_header2

“Kategorien” wäre das letzte, wo ich danach gesucht hätte (bzw. habe). Ich finde das extrem unintuitiv platziert, wahrscheinlich ist aber vor allem die deutsche Übersetzung (“Kategorien”) hier besonders schlecht.

Vielleicht verkürzt dieser Beitrag ja jemandem die verzweifelte Suche.

27. March 2014

TeXworks: Compiling your main.tex from an included part

Filed under: Uncategorized — Tags: , — Christopher Kramer @ 18:31

In case you have split your LaTeX document (let’s say main.tex) into multiple parts (let’s say part01.tex, …) and use include or input to stick it back together, you cannot compile part01.tex because it misses all the header stuff. So you need to compile main.tex. But is there a way in TeXworks to compile it using the Play-Button or CTRL+T?

Yes, there is. Add this line at the top of part01.tex etc:

% !TEX root = main.tex

Then just compile your files normally. It will compile main.tex, show the main.pdf in the preview and you can even navigate nicely using the context menu from pdf to tex and back.

11. October 2013

Stupid Spammers posting all their spam stock at once

Filed under: Uncategorized — Tags: — Christopher Kramer @ 14:47

Today I got this spam comment with probably all the possible spam combinations this spammer uses:

spam

This is only the first part, the complete comment is about 5 times as long. I guess it’s not the best approach to give all your beautiful spam away at once. Not only because only a complete fool would not mark this as spam but also because it’s probably the best way to make sure that spam filters will detect all your stuff 😀

12. April 2013

Russian localization available for phpLiteAdmin

Filed under: PHP,phpLiteAdmin,Uncategorized — Tags: , , , , — Christopher Kramer @ 00:44

phpLiteAdmin, a web GUI for SQLite databases written in PHP, has now been translated into Russian!

Thanks to Boris Kurshev (13dagger) for the translation. It is available for download from the official website.

To install localization packages for phpLiteAdmin, just unzip them in the phpLiteAdmin folder or the “languages” subfolder and adjust $language in the configuration (e.g. to “ru” for Russian).

It is very easy to translate phpLiteAdmin into your language. Everything is explained very well in the wiki. You can also find other localization packages there for German and Russian. If your language is not yet translated, please do so and send us the file in our discussion group.

Russian phpLiteAdmin

Russian phpLiteAdmin

 

11. December 2012

VIA VT6421 SATA RAID Controller: Hardware Initiate Failed (HDD)

Filed under: Uncategorized — Tags: , , , , , , , , , , , , , , — Christopher Kramer @ 21:24

My home-server’s motherboard is quite old and does not have onboard SATA. Therefore, when I bought a new hard drive for the server, I connected it to a PCI SATA controller card. Performance doesn’t matter much with this server (I am the only user, it mostly only runs cronjobs and the-like). The SATA card had a VIA VT6421 chip on it. From time to time, I had the problem that the computer wouldn’t boot failing with this error message:

Hardware Initiate failed. Please check Device.
The BIOS does not be installed. Press g to Continue.

Nice error message 😉
If you google this, you’ll find lots of people with this problem.

When I pressed CTRL+ALT+DEL to reboot the pc, it always detected the drive then. On the internet I found out that the problem is caused by SATA 300 (3Gbit/s) hard drives attached to the VT6421, which only supports SATA 150 (1,5Gbit/s). The Samsung drive I had at this time (a Samsung F2 EcoGreen 1500GB HD154UI 5400/m) didn’t have a jumper to change to SATA 150 (like some drives have), but Samsung provided a bootable tool to change the speed setting of the drive. (Samsung does not produce hard drives any longer, so I couldn’t find the software on the Samsung site anymore. I have it burnt on a CD, though. Contact me in case Samsung doesn’t publish it any longer and you really need it.)

Using the tool with the Samsung drive didn’t really solve the problem for me. But as it only occurred from time to time, I did not invest any more time to solve the problem.

Then one day the Samsung drive died 🙁 and I bought a new drive. This time it was a Seagate drive (Seagate 2000GB Barracuda Green ST2000DL003). With this drive, the problem occurred every time I booted the pc. As before, restarting the computer made it detect the drive, but it was very annoying. This drive has a jumper to set the speed to SATA 150. I inserted the jumper as described on the Seagate website (attention! look at the graphic twice because it is drawn upside-down!). The problem remained unchanged :(.

Finally, I found the solution to my problem while googling forums again. Somebody wrote that he could not make the SATA controller detect the drive since he disconnected the dvd drive (sorry I cannot give the link, I do not remember where I read it. Thanks a lot to the guy who wrote this nevertheless!). So I connected an unused dvd drive to the IDE port of the sata controller board (I did not use the IDE ports of the VT6421 card at all before, only the sata ports). And from now on, the controller detected the drive correctly! 🙂

So the short story is: Connect some additional device like a dvd drive to the IDE port of the controller card to solve the SATA problem!
At lest it worked for me. Maybe you additionally need the jumper as well (I did not remove it).

Kind of weird. I guess detecting the IDE device makes the controller busy for a moment so the drive is ready once the controller tries to detect it. But that’s only guessing.

I hope this helps somebody with the same problem. Please share your experience in the comments if it helped you.

Older Posts »